#!/bin/sh
if test -x /usr/bin/update-menus; then update-menus; fi
NAME=python@VERSION@-twisted
case "$1" in
configure|abort-upgrade|abort-remove|abort-deconfigure)
dpkg --listfiles $NAME | grep '\.py$' | \
xargs /usr/bin/python@VERSION@ -c 'import py_compile,sys
for file in sys.argv[1:]:
py_compile.compile(file)'
dpkg --listfiles $NAME | grep '\.py$' | \
xargs /usr/bin/python@VERSION@ -O -c 'import py_compile,sys
for file in sys.argv[1:]:
py_compile.compile(file)'
;;
esac
syntax highlighted by Code2HTML, v. 0.9.1